Account details section is not showing the correct emails sent for marketing campaigns

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix implemented and confirmed that issues surrounding the account details section not showing the correct emails sent for marketing campaigns, has been resolved. All services are now operational at this time.
Posted Jul 24, 2025 - 13:14 PDT

Monitoring

Our engineering team identified the cause and a fix has been deployed in production. We will continue monitoring the issue.
Posted Jul 24, 2025 - 10:59 PDT

Identified

Our engineering team has identified the issue and are currently working on it.
Posted Jul 24, 2025 - 10:45 PDT

Investigating

Our team has identified that the marketing campaigns email field is not showing the correct usage, our engineers have identified this and are currently working on it.
Posted Jul 24, 2025 - 09:17 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns).