Customers facing signup failures
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with signup failures has been resolved. All services are now operating normally at this time.
Posted Oct 18, 2024 - 13:25 PDT
Update
Our engineers are still monitoring system performance and no further updates are available at the moment to provide. We will provide more updates within the next hours or as soon as more info becomes available
Posted Oct 18, 2024 - 09:14 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. We will provide another update in one hour or as soon as more information becomes available.
Posted Oct 18, 2024 - 07:57 PDT
Update
We are continuing to investigate this issue.
Posted Oct 18, 2024 - 07:57 PDT
Update
We are continuing to investigate this issue.
Posted Oct 18, 2024 - 06:42 PDT
Investigating
Starting around 4:40 am PDT on 10/18/2024, we started observing some user signup failures. Engineering teams are triaging the impact. This does not affect mail send. We will provide another update in an hour, or as soon as updates become available.
Posted Oct 18, 2024 - 06:41 PDT
This incident affected: Website.