Delays with SendGrid Account Actions and Password Resets

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed the issue with account actions has been resolved. All services are now operating normally at this time.
Posted Jul 13, 2026 - 10:15 PDT

Monitoring

Our engineers have implemented a fix and are monitoring system performance. Account actions, such as password resets, are beginning to process as the system recovers and clears any remaining delays. As a reminder, this issue continues to have no impact on mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 13, 2026 - 09:36 PDT

Identified

Our engineers have identified the issue and are working toward a fix. Account actions, such as password resets, will continue to experience delays while the fix is being implemented. Please note that this does not impact mail send, which continues to process normally. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 13, 2026 - 09:23 PDT

Investigating

Starting around 8:58 AM PDT on July 13, 2026, our engineers began investigating an issue with account actions. Users may experience delays with account management tasks, such as password resets. This does not impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 13, 2026 - 09:13 PDT