Errors Accessing Twilio SendGrid Customer Support Systems
Incident Report for SendGrid
Resolved
This issue has been resolved. Any tickets that were successfully submitted during this time will be addressed by our team. We apologize for any inconvenience this caused you. Please contact our Support team at https://support.sendgrid.com with any questions.
Posted 28 days ago. Sep 16, 2019 - 13:40 PDT
Investigating
Our customer support system is currently unavailable. Customers may experience errors submitting support tickets via web or email, calling Twilio SendGrid customer support, or using live chat support. We have escalated the issue with our provider. We apologize for any inconvenience this has caused and will provide updates as we have information to share.
Posted 28 days ago. Sep 16, 2019 - 11:50 PDT
This incident affected: Website.