Latency affecting Automations Customers
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with Marketing Campaign Automations has been resolved. All services are now operating normally at this time.
Posted Mar 06, 2024 - 14:56 PST
Monitoring
Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 06, 2024 - 14:25 PST
Update
Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 06, 2024 - 14:25 PST
Update
Our engineers have identified the issue and are continuing to working toward a fix. At this time there is still some latency associated with emails being processed using the Automations feature. We will provide another update in hour or as soon as more information becomes available.
Posted Mar 06, 2024 - 13:51 PST
Identified
Our engineers have identified the issue and are working toward a fix. At this time there is still some latency associated with emails being processed using the Automations feature. We will provide another update in hour or as soon as more information becomes available.
Posted Mar 06, 2024 - 12:50 PST
Investigating
Starting around 11:36am PT on March 6, our engineers began investigating an issue that is resulting in increased latency among a certain subset of customers. This latency may especially be noticeable for users of the "Automations" feature associated with our Marketing campaigns product. Customers may see a delay of up to 90 minutes when processing Automations, but it is expected that those emails will be processed. The email API endpoint is unaffected. We will provide another update in an hour, or as soon as more information becomes available.
Posted Mar 06, 2024 - 11:53 PST
This incident affected: Marketing Campaigns (Marketing Campaigns).