Sender Authentication Verification Failures
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed that the issue with the ability to verify new instances of Sender Authentication is operating as expected at this time.
Posted Nov 04, 2023 - 20:48 PDT
Monitoring
Mitigation measures have been applied. Our third party vendor has implemented a fix and Sender Authentication Verification is working as expected. Our Engineering team is monitoring system performance now. Further update on this will be in the next 30 minutes.
Posted Nov 04, 2023 - 19:47 PDT
Update
The third-party service provider is still working on a solution for this. Twilio-SendGrid users may still continue to experience difficulties verifying recent instances of Sender Authentication. Our Engineering team is currently monitoring the system performance and working on the domain authentication creation backlog. We will provide an update within the next 12 hours, or as soon as we have any development on this.
Posted Nov 04, 2023 - 08:25 PDT
Update
The third-party service provider is still working on a solution on this. Twilio-SendGrid users may still continue to experience difficulties verifying recent instances of Sender Authentication. Our Engineering team is currently monitoring the system performance and working on the domain authentication creation backlog. We will provide an update within the next 12 hours, or as soon as we have any development on this.
Posted Nov 04, 2023 - 00:58 PDT
Identified
The third-party service provider is continuing to work toward a fix. Users may continue to see issues with the ability to verify new instances of Sender Authentication. Our Engineering team is monitoring system performance and working towards the queue of domain creation. Further updates will be in the next 12 hours or as soon as we have more information.
Posted Nov 03, 2023 - 10:41 PDT
Update
Our engineering team is still monitoring system performance for all pending queues of domain creation. Furthermore, the fix applied by our third party vendor for Sender Authentication Verification is working as expected. Further updates will be in the next 12 hours or as soon as we have more information.
Posted Nov 03, 2023 - 08:24 PDT
Update
Mitigation measures have been applied. Our third party vendor has implemented a fix and Sender Authentication Verification is working as expected. Our Engineering team is monitoring system performance and working towards the queue of domain creation. Further updates will be in the next 12 hours.
Posted Nov 02, 2023 - 19:44 PDT
Monitoring
Our third party vendor has implemented a fix and Sender Authentication Verification is working as expected. Our Engineering team is monitoring system performance and working towards the queue of domain creation. We will provide another update as soon as more information becomes available.
Posted Nov 02, 2023 - 18:26 PDT
Update
The third-party service provider is continuing to work toward a fix. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Nov 02, 2023 - 14:59 PDT
Update
The third-party service provider is continuing to work toward a fix. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 02, 2023 - 12:59 PDT
Update
The third-party service provider is continuing to work toward a fix. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 02, 2023 - 11:59 PDT
Update
The third-party service provider is continuing to work toward a fix. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 02, 2023 - 10:59 PDT
Update
The third-party service is continuing to work toward a fix. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 02, 2023 - 09:59 PDT
Identified
Our engineers have identified the issue and the third-party service is working toward a fix. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 02, 2023 - 08:59 PDT
Investigating
Starting around 8:06 AM PT, our engineers began investigating an issue with the ability to verify new instances of Sender Authentication. This is due to an issue with a third-party service and we are in contact with them to resolve the issue. This does not impact mail send or the ability to create Sender Authentication records. We will provide another update within 1 hour or as soon as more information becomes available.
Posted Nov 02, 2023 - 08:19 PDT
This incident affected: Partners.