Contact SendGrid UI is not loading for users
Incident Report for SendGrid
Resolved
Our engineers have deployed and monitored a fix and confirmed the issue has been resolved. All services are now operating normally at this time.
Posted Feb 26, 2024 - 09:41 PST
Investigating
Starting around 8:25 AM Pacific Time on Monday 02/26. We began experiencing issues with the sendgrid.com website. Customers may be unable to load Single Sends or Contacts in the UI dashboard of their accounts. In addition, mail send for Single Sends is impacted as well. Our engineering team is investigating the issue and we will provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 26, 2024 - 08:57 PST
This incident affected: Marketing Campaigns (Marketing Campaigns) and Mail Sending (API v3, SMTP, API v2).