New Signups, Upgrades and Marketing Campaign Failures
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issues with account sign-up and upgrades, Marketing Campaigns and Legacy Marketing Campaigns, template retrievals, and Email Validations API have all been resolved. All services related to this are now operating normally at this time. We appreciate your patience and understanding through this.
Posted Nov 24, 2021 - 12:33 PST
Monitoring
Our teams have identified and monitoring fixes in place for the remaining issues related to Email Validations API. We will provide another update in the next 30 minutes or as soon as more information becomes available.
Posted Nov 24, 2021 - 12:03 PST
Update
At this time, our team has identified and began monitoring a fix associated to the account creation, upgrades and Marketing Campaigns. We are still investigating the related issues related to utilizing Email Validations API. We will provide an update within the next 30 minutes or as we uncover more information.
Posted Nov 24, 2021 - 11:53 PST
Update
As we continue to investigate this issue, we are beginning to see additional failures related to templates as well as the Email Validations API. At this point, customers may experience issues related to account creation, account upgrades, Marketing Campaigns and Legacy Marketing Campaigns, retrieving select templates and utilizing Email Validations API
Posted Nov 24, 2021 - 11:36 PST
Investigating
Starting around 10:45am PST on November 23rd 2021, our engineers began investigating an issue where some accounts encounter issues tied to account creation, upgrades, as well as marketing campaigns. This does not impact mail send at this time and we are continuing to measure the scope of impact. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Nov 24, 2021 - 11:17 PST
This incident affected: Marketing Campaigns (Marketing Campaigns) and API, Website.