Stats Delays Due to Increased Latency and Timeouts

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed that the delays across the Stats service have been resolved. All services are now operating normally.
Posted Dec 03, 2025 - 21:23 PST

Monitoring

Between 01:32 to 02:12 AM UTC increased latency and timeouts were observed which resulted in delays across the Stats service, including global stats, advanced stats, and category stats. All latencies have returned to normal. We will provide another update in one hour or sooner if additional information becomes available.
Posted Dec 03, 2025 - 20:31 PST
This incident affected: Statistics.