Our engineers have validated that the issue has been resolved and all delayed mail have been caught up. All affected services are now operational.
Posted 4 years ago. Apr 26, 2021 - 08:07 PDT
Monitoring
We have implemented a fix and are monitoring system performance. A subset of delayed mail are still being dequeued. We will provide another update in an hour or as soon as more information becomes available.
Posted 4 years ago. Apr 26, 2021 - 07:16 PDT
Identified
Our Engineers have identified the issue and working towards processing all delayed mail. A small subset of customers may still see some mail send delays. We will provide another update in an hour or as soon as more information becomes available.
Posted 4 years ago. Apr 26, 2021 - 06:14 PDT
Investigating
As of 4.00am PT, our engineers are investigating an issue with one of our data centers. At this time, there will be mail delays for a small subset of customers. We will provide another update in 1 hour or as soon as more information becomes available.
Posted 4 years ago. Apr 26, 2021 - 05:15 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns) and Mail Sending (API v3, SMTP, API v2).