Issue with Marketing Campaigns

Incident Report for SendGrid

Resolved

This incident has been resolved.
Posted Apr 07, 2025 - 21:12 PDT

Update

Our engineers have monitored the fix and confirmed the issue with importing new Marketing Campaigns contacts and updating Marketing Campaign Automations has been resolved. All services are operating normally at this time.
Posted Apr 07, 2025 - 21:12 PDT

Monitoring

Our engineers have implemented a fix for the issue related to importing new Marketing Campaigns contacts and updating Marketing Campaign Automations. They are actively monitoring system performance. We will provide another update as soon as more information becomes available.
Posted Apr 07, 2025 - 21:08 PDT

Investigating

Starting around 2:15 pm PST today, our engineers began investigating an issue with Marketing Campaigns. Users may experience issues with importing new Marketing Campaigns contacts and updating Marketing Campaign Automations. This does not impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 07, 2025 - 15:39 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns).