Email Activity Feed Delays

Incident Report for SendGrid

Resolved

This incident has been resolved.
Posted 18 days ago. Mar 20, 2025 - 18:38 PDT

Identified

Our engineers have identified the issue and are working towards a fix. We will provide another update as soon as more information becomes available.
Posted 18 days ago. Mar 20, 2025 - 16:54 PDT

Investigating

Starting around 10:40 AM PST, our engineers began investigating an issue causing delays in the Email Activity Feed. We are actively working on identifying the root cause. The next update will be provided in one hour or sooner if more information becomes available.
Posted 18 days ago. Mar 20, 2025 - 16:00 PDT
This incident affected: Email Activity.