Service Disruption: Mail Delays
Incident Report for SendGrid
Resolved
After monitoring, we can confirm that the source of the disruption has been fixed and associated mail delays have been resolved. We sincerely apologize for any inconvenience this issue may have caused and greatly appreciate your patience. Please contact our Support team at https://support.sendgrid.com with any questions.
Posted 6 months ago. Apr 17, 2019 - 11:23 PDT
Monitoring
Our team has identified the source of these delays and implemented a fix. Delayed messages associated with this disruption have been sent and sending queues have returned to normal levels. We are continuing to monitor the situation and will provide an update when we can confirm the issue has been resolved. We apologize for any inconvenience this caused you. Please contact our Support team with any questions at https://support.sendgrid.com
Posted 6 months ago. Apr 17, 2019 - 10:50 PDT
Investigating
A subset of our customers may be experiencing delayed mail starting at approximately 9:15am MT, on April 17th, 2019. We have shifted traffic away from the affected data center and are investigating the cause of this issue. We apologize for any inconvenience this may be causing you. Please contact our Support team at https://support.sendgrid.com with any questions.
Posted 6 months ago. Apr 17, 2019 - 10:09 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2).