Our engineers have monitored the fix and confirmed the issue with Marketing Campaign emails has been resolved. All services are now operating normally at this time.
Posted 8 days ago. Mar 06, 2025 - 15:51 PST
Update
We are continuing to monitor for any further issues.
Posted 8 days ago. Mar 06, 2025 - 14:42 PST
Monitoring
Our engineers have implemented a fix and are monitoring system performance regarding charges associated to emails being sent to unsubscribed addresses. We will provide another update in an hour or as soon as more information becomes available.
Posted 8 days ago. Mar 06, 2025 - 13:42 PST
Identified
At 11:50 PST our engineers identified the cause of the issue and started working towards a solution. The engineering team is currently performing tests to implement the fix. We will provide another update in one hour or as soon as more information becomes available.
Posted 8 days ago. Mar 06, 2025 - 12:16 PST
Investigating
Starting around 11 AM PST on March 6, 2025, our engineers identified an issue where Marketing Campaign emails, including Automations and Single Sends, are generating charges in customer billing even if the email was dropped due to being in the Unsubscribed suppression list. As such, the situation might impact the user’s billing. This does not impact mail send. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted 8 days ago. Mar 06, 2025 - 11:52 PST
This incident affected: Marketing Campaigns (Marketing Campaigns) and Billing.