Domain Authentication Validation Delays
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue has been resolved. All services are now operating normally at this time.
Posted Mar 30, 2021 - 12:14 PDT
Monitoring
Monitoring: A fix has been implemented and we are no longer seeing 500 responses or delays when attempting to validate Domain Authentication. We will continue to monitor for stability and will provide another update in 30 minutes.
Posted Mar 30, 2021 - 11:41 PDT
Identified
Our engineers have identified the issue and are working towards a fix. Customers may still notice 500 responses and delays when attempting to validate domain authentication. We will provide updates in the next hour or as soon as they become available.
Posted Mar 30, 2021 - 11:11 PDT
Update
We are continuing to investigate this issue.
Posted Mar 30, 2021 - 11:01 PDT
Investigating
Starting around 5 PM PST on March 29, 2021 we began experiencing issues with Domain Authentication validation within the UI or via API. Customers may see a 500 error when attempting to validate domain authentication. This could cause delays in attempts to validate domain authentication. Our engineers are investigating the issue. We will provide updates within the next hour or sooner as they become available.
Posted Mar 30, 2021 - 10:49 PDT
This incident affected: API and Website.