Unable to Provision Subusers Created with V2 Subuser Management Endpoint
Incident Report for SendGrid
Resolved
Our engineers have finsihed monitoring the deployed fix and confirmed the provisioning problem with the v2 sub user API has been resolved. All services are now operating normally at this time.
Posted Oct 24, 2023 - 15:20 PDT
Monitoring
A fix to the v2 API sub user creation and provisioning problem has been deployed at 1:18 PM PT. At this time, new sub user accounts created specifically with the v2 API are showing to be properly provisioned after creation. As a reminder, this issue did not affect v3 sub user creation and provisioning nor did it affect mail send in any way. We will monitor the deployed fix and provide another update shortly to confirm resolution of this issue.
Posted Oct 24, 2023 - 13:26 PDT
Identified
Our engineers have identified the issue and are working toward a fix. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 24, 2023 - 12:23 PDT
Update
Our engineers are continuing to investigate this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 24, 2023 - 11:57 PDT
Investigating
Starting around 10:36AM PT on October 24th, our engineers began investigating an issue where subusers are unable to complete provisioning when created with V2 API Subuser Management Endpoint. This does not impact the v3 endpoint. This does not impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 24, 2023 - 10:58 PDT
This incident affected: API.