Service Disruption - Increased Bounces for Google Domains
Incident Report for SendGrid
Resolved
We have received confirmation from our third party that this issue has been resolved. Users can now reattempt mail sends to domains with Google mx records. Please note some users may continue to see impacted mails listed as suppressed. Our engineers will be continuing to focus efforts on correcting this as soon as possible. We sincerely apologize for the inconvenience and thank you for your patience
Posted Dec 15, 2020 - 17:24 PST
Monitoring
We are monitoring as our third party works towards a resolution. In the mean time, we have converted the bounces on impacted mail sends to blocks so that future mail sends to those email addresses will be reattempted. We will be providing updates as they become available. Thank you for your patience.
Posted Dec 15, 2020 - 16:08 PST
Update
Due to increased bounces from domains with Google mx records, users may notice inflated bounce events on Stats, Email Activity, and Event Webhook. Email Validation for google hosted emails will also be impacted, in that each hard bounce is being added to email validation bounce lists. Our engineers are continuing to work towards mitigating the impact. We sincerely apologize for the inconvenience
Posted Dec 15, 2020 - 14:37 PST
Update
We are continuing to work on a fix for this issue.
Posted Dec 15, 2020 - 13:58 PST
Update
We are continuing to work on a fix for this issue.
Posted Dec 15, 2020 - 13:52 PST
Identified
Due to a third party incident starting around 12PM MT, users sending mail to domains with Google mx records may experience an increased number of bounces due to the response code that is being returned. Our engineers have identified the issue and are working towards mitigating the impact. We will provide updates as they become available. Thank you for your patience.
Posted Dec 15, 2020 - 13:44 PST
This incident affected: Webhooks (Event Webhook), Mail Sending (API v3, SMTP, API v2), and Email Activity.