Click Tracking Events Delayed and Minor Impact on Single Sends

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed the issue with click tracking and Single Sends has been resolved. All services are now operating normally at this time.
Posted 8 months ago. Aug 29, 2024 - 03:45 PDT

Monitoring

Our engineers have implemented a fix and are monitoring system performance. We will provide another update in hour or as soon as more information becomes available.
Posted 8 months ago. Aug 29, 2024 - 03:40 PDT

Update

We are continuing to work on a fix for this issue.
Posted 8 months ago. Aug 29, 2024 - 03:39 PDT

Identified

Due to incident with third-party vendors, between 1:40 AM Pacific Time and 2:50 AM Pacific Time on 29th Aug 2024, our engineers began investigating an issue with click tracking and Single Sends. Users may experience delays with click tracking events being updated and issues with Single Sends. This does/does not impact mail send. 

Our engineers have identified the issue and are working toward a fix. We will provide another update in hour or as soon as more information becomes available.
Posted 8 months ago. Aug 29, 2024 - 03:32 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns) and Email Activity.