Heroku SendGrid Plan Change Failures
Incident Report for SendGrid
Resolved
Our engineers have monitored the Heroku SendGrid plan fix and confirmed that subscription changes with this partner platform now function properly. All services are now operating normally at this time.
Posted Mar 09, 2023 - 15:44 PST
Monitoring
Our engineers identified the root cause for the problem that prevented proper plan changes for Heroku SendGrid subscriptions and implemented a fix. After testing plan changes for Heroku, these changes now operate as expected and the system is functioning properly. We will monitor the update for the next 30 minutes before confirming this as resolved.
Posted Mar 09, 2023 - 15:11 PST
Investigating
Starting at 2:04 PM PT on March 9th, our engineers began investigating a technical issue in which users of the Heroku partner platform faced 500 errors when attempting to upgrade, downgrade or provision their SendGrid Heroku plans. This issue began at 4 AM PT on March 8th. This only impacts Heroku SendGrid subscription package changes and does not impact any other of our partner subscriptions. This issue does not affect mail send. Another update will be provided as soon as more information is available or within the next hour.
Posted Mar 09, 2023 - 14:31 PST
This incident affected: Partners.