Technical Incident - Some SendGrid System Generated Emails Resulting in Certificate Errors
Incident Report for SendGrid
Resolved
After monitoring the fix we are confident that this issue has been resolved. Customers should no longer be experiencing Certificate errors when clicking on links contained within SendGrid system generated emails such as password resets, teammate invites, contact exports etc. If you should experience a Certificate error, please resend the email and then clear your browser's cache before clicking the link or open said link in an incognito browser. We apologize for any inconvenience and thank you for your patience.
Posted Jan 08, 2021 - 12:26 PST
Monitoring
Engineers have uncovered the source of the issue and have implemented a fix and will continue to monitor. Customers should no longer be experiencing Certificate errors when clicking on links contained within SendGrid system generated emails such as password resets, teammate invites, contact exports etc. If you should experience a Certificate error, please resend the email and then clear your browser's cache before clicking the link or open said link in an incognito browser. We apologize for any inconvenience and thank you for your patience.
Posted Jan 08, 2021 - 11:44 PST
Investigating
Engineers are currently investigating reports that customers are receiving SendGrid system generated emails resulting in Certificate errors when included links are clicked. At this time we do not believe this has any impact on any customer initiated sends, this appears to be exclusive to some SendGrid system emails such as password resets, teammate invites, contact exports etc. We will provide an update within the next 60 minutes, or less as updates become available. We apologize for any inconvenience and thank you for your patience.
Posted Jan 08, 2021 - 10:34 PST
This incident affected: Website.