API Connection Errors and V2 Global Stats Delays
Incident Report for SendGrid
Resolved
Our engineers have monitored all impacted systems and confirmed all issues have been resolved. All services are now operating normally at this time.
Posted May 18, 2021 - 19:37 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. All systems are now fully operational. We will provide another update in an hour or as soon as more information becomes available.
Posted May 18, 2021 - 19:06 PDT
Update
Our engineers are continuing to work on a fix for this issue. Customers may still experience intermittent issues with impacted systems. We will provide another update within an hour or sooner if more information becomes available.
Posted May 18, 2021 - 18:42 PDT
Update
Our engineers are continuing to work towards a fix for this issue. We will provide another update within an hour or sooner if more information becomes available.
Posted May 18, 2021 - 17:42 PDT
Identified
Our engineers have identified the issue and are working on implementing a fix. Customers may continue to see authentication failures when attempting to log in. Customers should be able to log into upon reattempting. V2 Global Stats, Email Activity Feed, Mail Send, Legacy Marketing Campaigns, Unsubscribes, new account creation, and password resets are no longer impacted. We will provide updates in the next hour or sooner as they become available.
Posted May 18, 2021 - 16:45 PDT
Update
Our engineers are continuing to investigate issues with V2 Global Stats, Email Activity Feed, Mail Send, Legacy Marketing Campaigns, Unsubscribes. Customers may experience intermittent issues with these services including login failures, increased site latency, new account creation failures, and failed password resets. We will provide an update within an hour or as more information becomes available.
Posted May 18, 2021 - 15:45 PDT
Investigating
Starting around 2:20 P.M. PDT, our engineers began investigating an issue with Mail Send, V2 Global Stats, Email Activity Feed, Legacy Marketing Campaigns, and Unsubscribes. At this time, customers may see 500 errors when accessing these systems. We will provide another update within an hour or as more information becomes available.
Posted May 18, 2021 - 14:41 PDT
This incident affected: Mail Sending (API v3, API v2), Marketing Campaigns (Marketing Campaigns), and API, Website, Statistics, Email Activity.