Technical Incident - Mail Send Delays
Incident Report for SendGrid
Resolved
We have monitored the fix and confirmed that the issue has been resolved. We thank you for your patience and apologize for any inconvenience this may have caused.
Posted Nov 13, 2020 - 19:50 PST
Monitoring
We have implemented a fix and are monitoring system performance. Delayed mail, webhook posts, and stats appear to be catching up. We will continue to provide updates every 60 minutes or sooner if information becomes available. We apologize for any inconvenience this may cause.
Posted Nov 13, 2020 - 19:30 PST
Identified
We have identified the issue and are working on implementing a fix. We are slowly starting to see some of the impacted mail getting processed and delivered again. We will continue to provide updates every 60 minutes or sooner if information becomes available. We apologize for any inconvenience this may cause.
Posted Nov 13, 2020 - 19:10 PST
Update
We are still investigating the issue and will provide updates every 60 minutes or sooner if information becomes available. We apologize for any inconvenience this may cause.
Posted Nov 13, 2020 - 18:08 PST
Investigating
Starting around 5:10pm MT, a subset of customers may be experiencing delays around the processing or delivering of mail. Stats and webhook posts may also be delayed for those mail related events. We are investigating the issue and will provide updates every 60 minutes or sooner if information becomes available. We apologize for any inconvenience this may cause.
Posted Nov 13, 2020 - 17:09 PST
This incident affected: Webhooks (Event Webhook, Parse API), Mail Sending (API v3, SMTP, API v2), and Other Services (Email Activity).