Delay in Global Statistics

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed the issue with our Global Statistics has been resolved. All services are now operating normally at this time.
Posted 8 days ago. Mar 06, 2025 - 10:13 PST

Monitoring

Our engineers have implemented a fix and are currently monitoring system performance. Another update will be provided as soon as more information becomes available.
Posted 9 days ago. Mar 05, 2025 - 18:06 PST

Identified

Starting around 4:00 PM PT on March 5th 2025, our engineers began investigating an issue with Global Statistics being delayed. The issue has been identified around 5:20 PM PT and currently working towards a fix, there should not be any new impact at this time. We will provide another update as soon as more information becomes available.
Posted 9 days ago. Mar 05, 2025 - 17:49 PST
This incident affected: Statistics.