2FA codes not being received by SendGrid customers
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue regarding two-factor authentication codes via SMS has been resolved. All services are now operating normally at this time.
Posted Dec 12, 2022 - 07:22 PST
Monitoring
Our engineers have implemented a fix and are monitoring system performance. Customers should be able to log in using 2FA.
We will provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 12, 2022 - 06:21 PST
Update
Our engineers have implemented a fix and are monitoring system performance. Customers should be able to log in using 2FA.
However, some regions may experience delays in obtaining a 2FA SMS code. This does not impact mail send.

We will provide another update in an hour or as soon as more information becomes available.
Posted Dec 12, 2022 - 05:21 PST
Investigating
Our engineers have implemented a fix and are monitoring system performance. Customers should be able to log in using 2FA.
However, some regions may experience delays in obtaining a 2FA SMS code. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 12, 2022 - 03:50 PST
Monitoring
Our engineers have implemented a fix and are monitoring system performance. Customers should be able to log in using 2FA.
However, some regions may experience delays in obtaining a 2FA SMS code. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 12, 2022 - 03:32 PST
Update
Our engineers are still investigating the issue with the Two-Factor authentication codes delays over SMS. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 12, 2022 - 02:15 PST
Investigating
On December 11, 2022, at about 9:00 PM PT, we noticed a problem where customers were unable to log in to their accounts because they had not received the two-factor authentication codes. Customers may have difficulties while attempting to access their accounts using an SMS code. This does not affect users who use the Authy app, only those who verify through SMS. Our engineers are currently investigating this and we will provide another update in an hour or as soon as more information becomes available.
Posted Dec 12, 2022 - 01:08 PST
This incident affected: Website.