5xx Errors When Clicking Links

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed the issue with link resolution has been resolved. All services are operating normally at this time.
Posted 2 days ago. Apr 07, 2025 - 09:13 PDT

Update

Our engineers have implemented a fix for the issue related to the links were encountering 5xx errors. They are actively monitoring system performance. We will provide another update as soon as more information becomes available.
Posted 5 days ago. Apr 03, 2025 - 21:44 PDT

Monitoring

Our engineers have implemented a fix for the issue related to the links were encountering 5xx errors. They are actively monitoring system performance. We will provide another update as soon as more information becomes available.
Posted 5 days ago. Apr 03, 2025 - 19:09 PDT

Identified

Our engineers have identified the issue related to the links were encountering 5xx errors. They are actively working toward a fix, and we will provide another update as soon as more information becomes available.
Posted 5 days ago. Apr 03, 2025 - 19:08 PDT

Investigating

At 5:37 PM PT on April 3rd, our engineers began investigating an issue where links were encountering 5xx errors. Users may experience issues with their links, both branded and non-branded, within their emails. This issue does not impact mail send. We will provide another update in one hour or as soon as more information becomes available.
Posted 6 days ago. Apr 03, 2025 - 18:16 PDT
This incident affected: Mail Sending (API v3).