Increased Microsoft Inbox Provider Blocks

Incident Report for SendGrid

Update

Our engineering team is still actively investigating this issue and we will provide more updates as soon as they become available.
Posted Jan 23, 2026 - 03:22 PST

Update

Our engineering team is actively investigating this issue and we will provide more updates as soon as they become available.
Posted Jan 22, 2026 - 16:18 PST

Investigating

Starting around 3:00 am PST on January 14th, our engineers began investigating an issue with emails sent to Microsoft Outlook Consumer domains. Some customers may experience an increase in email block rates to Microsoft Outlook Consumer domains which include Hotmail and Outlook domains. Our Engineers are working with Microsoft. We will provide another update in two hours or as soon as more information becomes available.
Posted Jan 22, 2026 - 14:07 PST