Global Statistics experiencing delays

Incident Report for SendGrid

Resolved

This incident has been resolved.
Posted 3 years ago. Aug 19, 2022 - 09:03 PDT

Update

We are continuing to monitor for any further issues.
Posted 3 years ago. Aug 19, 2022 - 08:50 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 3 years ago. Aug 19, 2022 - 08:05 PDT

Identified

Our engineers have identified the issue starting at 6.25 am PT and implemented a fix. Systems are recovering currently as we closely monitor it. An update will be provided as soon as we have more information available.
Posted 3 years ago. Aug 19, 2022 - 06:54 PDT

Investigating

Starting around 04:15 AM PT on August 19th, our engineers began investigating an issue with Global Statistics showing with delays due to some timeouts in our database. This does not impact API mail send. We will provide another update within an hour or sooner if more information becomes available.
Posted 3 years ago. Aug 19, 2022 - 05:41 PDT
This incident affected: Statistics.