Billing Package Changes delayed
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed that the issue with the Billing Package Changes (upgrades/downgrades) is operating as expected at this time.
Posted Dec 12, 2023 - 13:03 PST
Monitoring
Mitigation measures have been applied. Our engineering team has implemented a fix and the billing packages changes (upgrades/downgrades) is working as expected, without any delays. Our Engineering team is monitoring system performance now. Further update on this will be in the next 30 minutes.
Posted Dec 12, 2023 - 12:15 PST
Identified
Our engineering team is working toward a fix. Users may continue to see issues with the ability to immediately see the package (upgrades/downgrades) changes when performed within the SendGrid application, the users may experience delays seeing the updated information. Our Engineering team is monitoring system performance and working towards the billing package services. Further updates will be added in the next 1 hour or as soon as we have more information.
Posted Dec 12, 2023 - 11:32 PST
Investigating
Starting around 11:00AM PDT on December 12th, 2023, our engineers began investigating an issue with billing package changes being delayed. This issue is affecting the ability to immediately see the package (upgrades/downgrades) changes when performed within the Sendgrid application, the users may experience delays seeing the updated information. This does not impact mail send, neither credit card updates. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 12, 2023 - 11:08 PST
This incident affected: Billing.