A Subset of Marketing Campaign Users Are Unable to Send Single Sends or Display Contacts
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with Marketing Campaigns has been resolved. All services are now operating normally at this time.
Posted Apr 15, 2024 - 15:19 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 1 hour as soon as more information becomes available.
Posted Apr 15, 2024 - 14:46 PDT
Update
Our engineers have identified the issue and are still working toward a fix. We will provide another update in 1 hour or as soon as more information becomes available
Posted Apr 15, 2024 - 14:29 PDT
Update
Our engineers have identified the issue and are still working toward a fix. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 15, 2024 - 13:33 PDT
Identified
Our engineers have identified the issue and are working toward a fix.  We will provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 15, 2024 - 13:04 PDT
Investigating
Starting around 12:21PM PT on April 15th, our engineers began investigating an issue where a certain subset of Marketing Campaign users are unable to create or send Single Sends. The contacts page also does not load and users can experience errors. This does impact the Contacts List API. This does not impact API mail send.  We will provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 15, 2024 - 12:43 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns) and API, Website.