Service Disruption: Network Connectivity Issues
Incident Report for SendGrid
Resolved
Our engineers have validated that the issue has been resolved and all affected services are now fully operational. We sincerely apologize for the inconvenience and thank you for your patience.
Posted Feb 16, 2021 - 19:08 PST
Update
We are continuing to monitor the performance of our systems. We will provide updates in the next 30 minutes or sooner as they become available. We appreciate your patience.
Posted Feb 16, 2021 - 18:32 PST
Update
Our engineers have implemented a fix and are now monitoring its performance. We are not expecting any customer impact at this time. We will provide updates in the next 30 minutes or sooner as they become available. We appreciate your patience.
Posted Feb 16, 2021 - 18:01 PST
Monitoring
Our engineers are monitoring the fix. There should not be any customer impact at this time. Thank you for your continued patience. We will provide updates in the next 30 minutes or sooner as they become available.
Posted Feb 16, 2021 - 17:28 PST
Update
At this time, our engineers are still working towards a resolution. Mail send via SMTP and API should be functioning as intended and no mail delays are being observed. Legacy and New Marketing Campaigns are recovering and not currently observing any known issues. In addition, customers are now able to log into the Support Help Center to submit a Support ticket. Thank you for your continued patience. We will provide updates in the next 30 minutes or sooner as they become available.
Posted Feb 16, 2021 - 17:07 PST
Update
At this time our engineers are still working on towards a resolution. Thank you for your continued patience.
Posted Feb 16, 2021 - 16:37 PST
Identified
Our engineering team has identified the issue and is working towards a fix. At this time, customers may still experience latency issues with accessing certain sections of new Marketing Campaigns via the UI or API. There are also delays for SMTP and API mail send. In addition, customers may have trouble logging into the Support Help Center to submit a Support ticket. We will provide updates as they become available. Thank you for your patience.
Posted Feb 16, 2021 - 16:04 PST
Update
We are continuing to work on investigating the cause of this issue. The current customer impact includes site errors, latency, and mail send delays for Legacy Marketing Campaigns. Customers may experience intermittent issues with accessing certain sections of new Marketing Campaigns via the UI or API. There are also delays for SMTP and API mail send. In addition, customers may have trouble logging into the Support Help Center to submit a Support ticket. We are working as quickly as possible to restore services for our customers. We will provide updates as soon as they become available.
Posted Feb 16, 2021 - 14:40 PST
Update
At this time our engineers are still working towards locating the cause of this issue. Thank you for your continued patience.
Posted Feb 16, 2021 - 13:10 PST
Update
Our engineers are continuing to actively work on investigating this issue. The current customer impact includes site errors, latency, and mail send delays for Legacy Marketing Campaigns. Some sections of new Marketing Campaigns may also be experiencing degradation.
There are also mail delays for messages sent via SMTP and API.
In addition, SSO beta teammates are reporting site errors and latency. We will provide updates as they become available. Thank you for your patience.
Posted Feb 16, 2021 - 11:48 PST
Update
We are continuing to work on investigating the cause of this issue. The current customer impact includes site errors, latency, and mail send delays for Legacy Marketing Campaigns. Some sections of new Marketing Campaigns may also be experiencing degradation.
There are also mail delays for messages sent via SMTP and API.
In addition, SSO beta teammates are reporting site errors and latency. We are working as quickly as possible to restore services for our customers. We will provide updates in the next hour or as soon as they become available.
Posted Feb 16, 2021 - 10:48 PST
Investigating
As of 10am MT, our engineers are investigating errors in one of our datacenters. Customers may experience timeout and 500 errors when trying to connect to our APIs and SMTP. Sender authentication as well as click-tracking may be impacted. Customers may also experience issues when accessing the legacy marketing-campaigns services via UI. Our engineers are actively investigating the situation. We apologize for any inconvenience this may cause.
Posted Feb 16, 2021 - 09:53 PST
This incident affected: Marketing Campaigns (Marketing Campaigns), Other Services (API), Mail Sending (API v3, SMTP), and Website.