Incorrect Single Send Stats in UI
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and are confident that the issue surrounding stats shown in the UI for Single Sends will now display accurately. All services are operating as expected at this time.
Posted Apr 06, 2022 - 11:33 PDT
Update
We are continuing to monitor the fix that was deployed for this issue. We will provide another update within 24 hours or as soon as more information becomes available.
Posted Apr 05, 2022 - 14:19 PDT
Update
We're continuing to monitor results of the fix that went out last week. Performance seems to be improving; however, we are still seeing instances where stats do not display correctly. We'll be providing an update in the next 24 hours or as soon as more details become available.
Posted Apr 04, 2022 - 12:30 PDT
Monitoring
Our engineers have implemented a fix for the Incorrect Stats for Single Sends issue and are monitoring system performance.  We will provide another update in the next 24 hours or as soon as more information becomes available.
Posted Apr 02, 2022 - 07:12 PDT
Update
Our engineers have identified a fix for the Incorrect Stats for Single Sends in which the fix is currently being tested.  We will provide another update in the next 24 hours or as soon as more information becomes available.
Posted Apr 01, 2022 - 07:42 PDT
Identified
Our engineers have identified the issue causing incorrect stats for Single Sends and are working towards a fix. At this time, customers may still experience incorrect Single Send stats when viewing within the UI or retrieving via API. We will provide another update in 24 hours or as more information becomes available.
Posted Mar 31, 2022 - 07:13 PDT
Update
Our engineers are still investigating this issue from the last update. We will provide another update in the next 24 hours or as soon as more information becomes available to our team. We appreciate and thank you for your patience as we continue to look into this.
Posted Mar 30, 2022 - 15:28 PDT
Update
Our engineers are still investigating this issue from the last update. We will provide another update in the next 24 hours or as soon as more information becomes available to our team. We thank you and appreciate your patience as we continue to look into this.
Posted Mar 29, 2022 - 14:53 PDT
Update
Our engineers are still investigating this issue from the last update. We will provide another update in the next 24 hours or as soon as more information becomes available to our team. We appreciate your patience as we continue to look into this.
Posted Mar 28, 2022 - 14:52 PDT
Update
Our engineers are still investigating this issue from the last update. We will provide another update in the next 24 hours or as soon as more information becomes available to our team. We appreciate your patience as we look into this.
Posted Mar 26, 2022 - 14:40 PDT
Update
Our engineers have attempted to implement a fix and are still investigating this issue to confirm if the issue is resolved. We will provide another update in the next 24 hours or as soon as more information becomes available to our team. We appreciate your patience as we look into this.
Posted Mar 25, 2022 - 15:11 PDT
Update
Our engineers are still investigating this issue from the last update. We will provide another update in the next 24 hours or as soon as more information becomes available to our team. We appreciate your patience as we look into this.
Posted Mar 24, 2022 - 18:59 PDT
Update
Our engineers are still investigating this issue from the last update. We will provide another update in the next 24 hours or as soon as more information becomes available to our team. We appreciate your patience as we look into this.
Posted Mar 23, 2022 - 18:49 PDT
Update
Our engineers are still investigating this issue from the last update. We will provide another update in the next 24 hours or as soon as more information becomes available to our team.
Posted Mar 22, 2022 - 19:08 PDT
Update
Our engineers are still investigating this issue from the last update. We will provide another update in the next eight hours or as soon as more information becomes available.
Posted Mar 22, 2022 - 14:18 PDT
Update
Our engineers are still investigating this issue. We will provide another update in the next four hours or as soon as more information becomes available.
Posted Mar 22, 2022 - 10:35 PDT
Investigating
Starting around 9am PT on March 22, our engineers began investigating an issue with Single Send stats within the UI. Customers may experience lower/inflated stats within the Single Send details page. This does not impact mail send. We will provide another update in an hour or as soon as more information becomes available.
Posted Mar 22, 2022 - 09:37 PDT
This incident affected: Statistics.