Email credit limits not removed after upgrading from a free account to a paid account
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with credit limits not being removed from accounts after they are upgraded from a Free to Paid plan has been resolved. All services are now operating normally at this time. We appreciate your patience and understanding as we worked to resolve this issue.
Posted Nov 24, 2021 - 17:49 PST
Update
Our engineers are currently monitoring the fix that was put in place and system performance. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Nov 24, 2021 - 17:18 PST
Update
Our engineers are currently monitoring the fix that was put in place and system performance. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Nov 24, 2021 - 16:46 PST
Monitoring
Our engineers have implemented a fix and are monitoring system performance. This fix in place has mitigated the issue for newly upgrading accounts and our team is currently working to remediate previously affected accounts related to this issue. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Nov 24, 2021 - 16:09 PST
Update
We are currently continuing to work towards a fix for this issue. We will provide another update within an hour or sooner as more information becomes available to our team.
Posted Nov 24, 2021 - 15:28 PST
Update
We are currently continuing to work towards a fix for this issue. We will provide another update within an hour or sooner as more information becomes available to our team.
Posted Nov 24, 2021 - 14:28 PST
Update
We are continuing to work towards a fix for this issue. We will provide another update within an hour or sooner if more information becomes available.
Posted Nov 24, 2021 - 13:30 PST
Identified
Our engineers have identified the issue preventing credit limits from being removed and are working towards a fix. We will provide another update within an hour or sooner if more information becomes available.
Posted Nov 24, 2021 - 12:33 PST
Investigating
At 11:37 AM PST on Wednesday, November 24, our engineers began investigating an issue with credit limits not being removed from accounts after they are upgraded from a Free to Paid plan. This will impact customers' ability to send over 100 emails per day until the limit is removed. This only impacts customers who have recently upgraded to a paid plan from a free plan. We will provide an update within an hour or when more information becomes available.
Posted Nov 24, 2021 - 12:00 PST