Technical Incident - Mail Send Delays
Incident Report for SendGrid
Resolved
After monitoring, we confirmed the issue with mail processing delays using ASM has been resolved. All services are now operating normally at this time.
Posted Jun 29, 2022 - 12:59 PDT
Monitoring
Our engineers have implemented a fix for the delayed mail and have monitored that mail has dequeued for the affected period. We will provide another update within an hour to confirm the issue is resolved or as soon as more information becomes available.
Posted Jun 29, 2022 - 12:27 PDT
Identified
Between 11:05 and 11:45 AM PT on June 29th, our engineers identified an issue with mail processing delays for a small subset of customers that sent mail using Advanced Subscription Management (ASM) during the aforementioned period. Since this time range and after an internal change, new mail is processing as expected. We will provide another update within an hour or as soon as more information becomes available while we monitor the stability of the changes that have been deployed.
Posted Jun 29, 2022 - 12:16 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns) and Mail Sending (API v3, SMTP, API v2).