Errors when accessing IP Access Management, Sender Authentication and Webhook settings
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with accessing IP Access Management, Sender Authentication and Event Webhook settings at the Sendgrid's User Interface has been resolved. All services are now operating normally at this time.
Posted Jan 18, 2024 - 20:55 PST
Monitoring
Our engineers have implemented a fix and are monitoring system performance. We will provide another update in the next 30 minutes, or as soon as more information becomes available.
Posted Jan 18, 2024 - 20:21 PST
Investigating
Starting around 6:00 PM PST on Thursday, January 18th, 2024, our engineers began investigating an issue with accessing IP Access Management, Sender Authentication and Webhook settings at the Sendgrid's User Interface. When accessing those features, customers are returned the error message "We encountered an error. We're sorry, we were unable to load the page." There's no impact to Mail Send functionality.

We are actively working to resolve the issue. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Jan 18, 2024 - 19:12 PST
This incident affected: Website.