Service Disruption: Mail Delays
Incident Report for SendGrid
Resolved
After monitoring, we can confirm that the source of the disruption has been fixed and associated mail delays have been resolved. We sincerely apologize for any inconvenience this issue may have caused and greatly appreciate your patience. Please contact our Support team at https://support.sendgrid.com with any questions.
Posted 3 months ago. Feb 02, 2019 - 10:34 PST
Monitoring
Our Operations team has identified the source of these delays and implemented a fix. Delayed messages associated with this disruption have been sent and sending queues have returned to normal levels. We are continuing to monitor the situation and will provide an update when we can confirm the issue has been resolved. We apologize for any inconvenience this caused you. Please contact our Support team with any questions at https://support.sendgrid.com
Posted 3 months ago. Feb 02, 2019 - 10:05 PST
Update
Our Operations team is continuing to investigate delayed mail for a subset of our customers. We will provide further updates as soon as we have more information. Please reach out to our Support team with any questions at https://support.sendgrid.com
Posted 3 months ago. Feb 02, 2019 - 09:45 PST
Investigating
A subset of our customers may be experiencing delayed mail starting at approximately 10:00pm MST, on February 1st, 2019. Our operations team is investigating the cause of this issue and we will provide updates here as they become available. We apologize for any inconvenience this may be causing you. Please contact our Support team at https://support.sendgrid.com with any questions.
Posted 3 months ago. Feb 02, 2019 - 09:09 PST
This incident affected: Mail Sending (API v3, SMTP, API v2).