Mail sending delays.

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed the issue with mail send has been resolved. All services are now operating normally at this time.
Posted Dec 03, 2025 - 17:09 PST

Monitoring

Starting around 4:10 PM PDT on 2/12/2025, our engineers began investigating an issue with mail send. Customers may have experienced delays during this time. The delay ended at approximately 4:41 PM PDT. We will continue to monitor the situation and provide another update in one hour or as soon as more information becomes available.
Posted Dec 03, 2025 - 16:57 PST

Investigating

Starting around 4:10 PM PDT on 2/12/2025, our engineers began investigating an issue with mail send. Customers may have experienced delays during this time. The delay ended at approximately 4:41 PM PDT. We will continue to monitor the situation and provide another update in one hour or as soon as more information becomes available.
Posted Dec 03, 2025 - 16:46 PST
This incident affected: Mail Sending (API v3).