Brazil customers not able to open support tickets for logging issues

Incident Report for SendGrid

Resolved

Our engineers have investigated the issue and determined that it is specific to certain browsers. We recommend that customers use a different browser to access the Support Help Center if they are experiencing this issue.
Posted 29 days ago. Feb 12, 2025 - 14:36 PST

Investigating

Starting around 2:10pm PST on Feb 12th, our engineers began investigating an issue with the SendGrid Help Center where unauthenticated customers located in Brazil are not being able to escalate login issues. When clicking the "Trouble Logging In" or "Forgot my Username" link, they are redirected to a "Not logged in" page. This does not impact mail send or authenticated customers who know their username and password. We will provide another update in an hour or as soon as more information becomes available.
Posted 29 days ago. Feb 12, 2025 - 14:31 PST
This incident affected: Website.