Delays in CNAME record propagation
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed that the issues with CNAME records propagation have been fully resolved at 7:33AM PT. All services related to this are now operating normally at this time. We appreciate your patience and understanding through this.
Posted Mar 12, 2022 - 07:37 PST
Monitoring
The issues with CNAME records propagation have been mitigated. To ensure system stability, engineering will continue to monitor the implemented fix.
We will provide another update in 8 hours or as soon as more information becomes available.
Posted Mar 12, 2022 - 03:13 PST
Update
Our engineers are still working on a fix to the CNAME records propagation problems. When updating, validating, or generating Sender Authentication entries, customers may experience DNS propagation delays, as well as SPF and DKIM errors in mail sends.
We will provide another update in 8 hours or as soon as more information becomes available.
Posted Mar 12, 2022 - 01:12 PST
Update
Our engineers are still working on a fix. At this time customers will experience DNS propagation delays when making updates, validating, or creating Sender Authentication records and may also observe SPF and DKIM failures in mail sends. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Mar 11, 2022 - 21:12 PST
Identified
Our engineers have identified the issue and are working toward a fix. Customers will see delays in DNS propagation when making updates, validating or creating Sender Authentication records and may observe SPF and DKIM failures in mail sends. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 11, 2022 - 19:15 PST
Investigating
Starting around 6:00 pm PT on Friday, March 11, 2022, our engineers began investigating an issue with CNAME records not propagating. Customers may experience delays in DNS propagation when updating, validating, or changing Sender Authentication records. This impacts SPF and DKIM passing in regards to mail send. We will provide another update in the next hour or as soon as more information becomes available.
Posted Mar 11, 2022 - 18:12 PST
This incident affected: Mail Sending (API v3, SMTP, API v2) and API, Website.