Incident: Mail Delays
Incident Report for SendGrid
Resolved
The source of the disruption has been fixed. Please be advised delayed mail was found to have been dropped in the process. We sincerely apologize for any inconvenience this issue may have caused and greatly appreciate your patience and understanding in this. Please contact our Support team at https://support.sendgrid.com with any questions.
Posted 4 months ago. Jun 19, 2019 - 13:24 PDT
Monitoring
Our team has identified the source of delayed email and implemented a fix. We are continuing to monitor the situation and will provide an update once the issue has been resolved. We apologize for any inconvenience this caused you. Please contact our Support team with any questions at https://support.sendgrid.com.
Posted 4 months ago. Jun 19, 2019 - 08:27 PDT
Investigating
We are investigating reports of customers experiencing mail delays starting at approximately 1AM MT, on June 19th, 2019. We apologize for any inconvenience this may be causing you. Please contact our Support team at https://support.sendgrid.com with any questions.
Posted 4 months ago. Jun 19, 2019 - 07:59 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2).