New SendGrid Direct Sign-ups Can Experience Login Failures

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed the issue with new Twilio SendGrid Direct login failures has been resolved. All services are now operating normally at this time.
Posted Mar 04, 2024 - 11:25 PST

Monitoring

Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 1 hour as soon as more information becomes available.
Posted Mar 04, 2024 - 10:56 PST

Update

New SendGrid Direct Sign-up can experiencing login failures
Posted Mar 04, 2024 - 10:38 PST

Update

New SendGrid Direct Sign-up can experiencing login failures
Posted Mar 04, 2024 - 10:38 PST

Investigating

Starting around 10:14 AM PST on March 4th 2024, our engineers began investigating an issue with Twilio SendGrid Direct Sign-ups. New user sign-ups may experience login failures. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 04, 2024 - 10:35 PST
This incident affected: Website.