Login issues reported from Azure users starting on 10/10/23
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with Azure customers unable to access their Twilio SendGrid accounts has been resolved. All services are now operating normally at this time.
Posted Oct 11, 2023 - 14:21 PDT
Monitoring
Engineers are still investigating the issue with our partners. However we are not seeing any new reports of issues for Azure customers with accessing their Twilio SendGrid account. Our team will continue to monitor this issue. We will follow up in 2 more hours, or as more information is available.
Posted Oct 11, 2023 - 12:56 PDT
Update
We are continuing to investigate reports of login issues starting yesterday evening. Some impacted accounts are showing the issue as resolved, please try logging in again if you were experiencing problems earlier.

Our engineering team is continuing to work with our partners to resolve this. We will provide another update in 1 hour, or as more information becomes available.
Posted Oct 11, 2023 - 11:51 PDT
Update
We are continuing to investigate reports of login issues starting yesterday evening, however we are seeing reduced numbers of new reports today. Our engineering team is continuing to work with our partners to resolve this. We will provide another update in 1 hour or as more information becomes available.
Posted Oct 11, 2023 - 09:54 PDT
Investigating
From around 9:47pm PST 10/10/2023, we started receiving reports about issues when users try to log into Twilio SendGrid accounts from the Azure Portal.
Affected customers when they try to click on "Open SaaS Account on publisher's site", they may see the link gray out. This is only affecting access when using SSO from Azure. Our engineering team is working with our partner to resolve this at this moment. This incident does not impact mail send. We will provide another update in an hour or as soon as more information becomes available.
Posted Oct 11, 2023 - 08:30 PDT
This incident affected: Partners.