False Bounces and Blocks for mail sent to icloud.com domains
Incident Report for SendGrid
Resolved
We have received confirmation from our third party that this issue has been resolved. Users can now reattempt mail sends to domains using iCloud MX records. Our engineers will be continuing to focus efforts on correcting the false bounces lists as soon as possible. Customers using Email Validation may see a decrease in validation scores of emails using iCloud MX records as we work to remedy this.
Posted Apr 26, 2021 - 10:59 PDT
Monitoring
At 10:17 AM PDT, the third-party service declared this outage over. We are continuing to monitor delivery to these domains. During this timeframe, customers will see an increase in bounces and blocks to these domains. We will provide updates within the next hour or as they become available.
Posted Apr 26, 2021 - 09:44 PDT
Investigating
Around 4.13am PT~, a third party service declared an incident that is impacting with mail sent to icloud.com domains including icloud.com, me.com, and mac.com. A subset of users may see false bounces and blocks when sending mail to these domains. We will provide updates within the next hour or as they become available.
Posted Apr 26, 2021 - 08:57 PDT