Customers in Argentina Unable to Authenticate Card in Twilio SendGrid

Incident Report for SendGrid

Update

Our engineering team is continuing to investigate this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 27, 2026 - 09:50 PST

Investigating

Starting around 8:40PM PDT on Friday, 2/27/25, our engineers are investigating an issue with Twilio SendGrid users in Argentina are unable to authenticate their credit cards. Customers in Argentina may not be unable to add their credit card into the system. This does not impact mail send. We will provide updates in the next hour or sooner as they become available.
Posted Feb 27, 2026 - 08:49 PST
This incident affects: Website.