Login Failures
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with Login Failures has been resolved. All services are now operating normally at this time.
Posted May 24, 2023 - 18:56 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. We will provide another update as soon as more information becomes available.
Posted May 24, 2023 - 18:35 PDT
Identified
We are actively working to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted May 24, 2023 - 18:15 PDT
Update
We are continuing to investigate this issue.
Posted May 24, 2023 - 17:29 PDT
Update
We are continuing to investigate this issue.
Posted May 24, 2023 - 17:26 PDT
Investigating
Starting around 5:06pm PT on 5/24/23, our engineers began investigating an issue with login failures with the Twilio SendGrid login page. Users may not be able to log into their account at this time. This may impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted May 24, 2023 - 17:23 PDT
This incident affected: Mail Sending (API v3) and API, Website.