Mail Send Duplicates and Delays
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue has been resolved. Our investigation and monitoring confirms only a small subset of delayed mail. All services are now operating normally at this time.
Posted Mar 31, 2021 - 18:33 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. All delayed mail has successfully de-queued. We will provide another update in an hour or as soon as more information becomes available.
Posted Mar 31, 2021 - 18:04 PDT
Identified
Our engineers have identified the issue and are working toward a fix. Delayed mail is now successfully de-queuing and no further duplicate mail is being processed. We will provide another update in an hour or as soon as more information becomes available.
Posted Mar 31, 2021 - 17:51 PDT
Investigating
Starting around 4:45pm PT, our engineers began investigating an issue that caused possible duplicate mail sends and delays. We will provide another update in an hour or as soon as more information becomes available.
Posted Mar 31, 2021 - 17:32 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns) and Mail Sending (API v3, SMTP, API v2).