Google Cloud Platform Email API Account Access
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with Google Cloud Platform Email API has been resolved. All services are now operating normally at this time.
Posted Jun 22, 2021 - 10:33 PDT
Monitoring
Our engineers have worked with Google Cloud Platform and have implemented a fix. We are monitoring performance and will provide another update in an hour or as soon as more information becomes available.
Posted Jun 22, 2021 - 09:41 PDT
Update
Our team is still investigating this issue and working towards a fix with Google Cloud Platform. We will provide a further update within 16 hours or sooner. As an alternative, existing customers still have access to their account via sendgrid.com with the account username and password or through the Marketing Campaigns link via Google Cloud Platform.
Posted Jun 22, 2021 - 08:24 PDT
Update
Our team is still investigating this issue and working towards a fix with Google Cloud Platform. We will provide a further update within 8 hours or sooner. As an alternative, existing customers still have access to their account via sendgrid.com with the account username and password or through the Marketing Campaigns link via Google Cloud Platform.
Posted Jun 22, 2021 - 00:24 PDT
Update
Our team is still investigating this issue and working towards a fix with Google Cloud Platform. We will provide a further update within 4 hours or sooner. As an alternative, existing customers still have access to their account via sendgrid.com with the account username and password or through the Marketing Campaigns link via Google Cloud Platform.
Posted Jun 21, 2021 - 20:24 PDT
Update
Our team is still investigating this issue and working towards a fix with Google Cloud Platform. We will provide a further update within 2 hours or sooner. As an alternative, existing customers still have access to their account via sendgrid.com with the account username and password or through the Marketing Campaigns link via Google Cloud Platform.
Posted Jun 21, 2021 - 18:24 PDT
Investigating
Starting around 2:21 PST on Monday June 21st we began investigating an issue regarding access to the SendGrid platform via the Google Cloud Platform Marketplace. Affected customers may not be able to access their accounts through the SendGrid Email API link in the Google Cloud Platform. This will also affect the ability to sign up for new SendGrid accounts and the ability to manage their plans through the Google Cloud Platform Marketplace via this link as well. Our team is working with our Google Cloud Platform teams towards a fix. As an alternative, existing customers still have access to their account via sendgrid.com with the account username and password or through the Marketing Campaigns link via Google Cloud Platform.
Posted Jun 21, 2021 - 17:23 PDT
This incident affected: Partners.