Customers temporarily unable to login
Incident Report for SendGrid
Resolved
Our engineers have identified the log in issue for legacy accounts that started at 10:47am PST and confirmed that it has been resolved around 1:00 PM PST. All services are now operating normally at this time.
Posted Nov 07, 2024 - 13:24 PST
Investigating
Starting around 12:30 PM CT, more details to come, customers starting reporting an issue when logging into their accounts. Our engineers are fully aware and actively investigating this issue. Mail Send is not affected. We'll be providing more details and updates within an hour as soon as they become available.
Posted Nov 07, 2024 - 13:05 PST