Teammates invited to SendGrid are prompted to create standalone Unified accounts instead of joining the inviting one

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed the issue with teammate account creation has been resolved. All services are now operating normally at this time.
Posted May 12, 2026 - 11:20 PDT

Monitoring

Our engineers have implemented a fix and are monitoring system performance. Teammates that were impacted by the issue need to request a new invite link and delete cache and cookies on their browsers before attempting to join again. We will provide another update in one hour or as soon as more information becomes available.
Posted May 12, 2026 - 10:13 PDT

Identified

Our engineers have identified the issue and are working toward a fix. We will provide another update in one hour or as soon as more information becomes available.
Posted May 12, 2026 - 09:59 PDT

Investigating

Starting around 9 AM PDT on Tuesday, 5/12/2026, our engineers started investigating an issue with teammates, where invitees could not join their organizations and instead they were led to creating standalone Twilio Unified accounts. New teammates, therefore, are unable to join their organizations at the time. This issue does not impact mail send. We will provide another update in an hour or as soon as more information becomes available.
Posted May 12, 2026 - 09:31 PDT