Duplicate Statistics for Email Advanced Statistics
Incident Report for SendGrid
Resolved
Our engineers have investigated and resolved the issues with duplicate Advanced Statistics. Around 1.58% of users may notice duplicate Advanced Statistics for the date of May 10th. Advanced Statistics include Mailbox Provider, Geographical, Browser, and Email Client & Devices Stats.
Posted May 10, 2023 - 11:39 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 1 hour or as soon as more information becomes available.
Posted May 10, 2023 - 11:12 PDT
Identified
Starting around 10 AM PT on May 10th, our engineers have identified an issue with Advanced Statistics for Twilio SendGrid API and the UI. Users may experience duplicate statistics for Advanced Statistics such as browser, mail box provider, and others. This does not impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted May 10, 2023 - 10:46 PDT
This incident affected: API, Statistics, and Email Activity.