SendGrid SMTP/API mail send failures

Incident Report for SendGrid

Resolved

Our engineers have monitored the issue and confirmed that is has been resolved. All services are now operating normally at this time.
Posted Mar 01, 2023 - 22:47 PST

Monitoring

We are still monitoring performance to make sure that the issue has been fully resolved post rollback.
Posted Mar 01, 2023 - 21:56 PST

Update

Certificate rollback has been completed for SMTP and API. We are still monitoring performance to make sure that the issue has been fully resolved.
Posted Mar 01, 2023 - 21:54 PST

Update

Our engineers have identified the issue and are working towards mitigation. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 01, 2023 - 20:59 PST

Identified

We have recently rolled out a new certificate change for SMTP and API while some clients are experiencing compatibility issue with new certificate.
Posted Mar 01, 2023 - 20:34 PST
This incident affected: Mail Sending (API v3, SMTP).